July 16th, 2013 | Tags: , , , , ,

Today we will be configuring LACP to interconnect some switch stacks as part of a network upgrade.  Please keep in mind that part of configuring the LAG will result in the ports losing connectivity, so while it is not necessary to use a console cable, please keep in mind how you are connecting to the switch and if you will interrupt that connection by any of your actions, and plan accordingly.

This environment is a small environment, which consists of a stacked pair of Dell Powerconnect 6248 as the core.  Which uses 2 10Gb connections (per pair) to connect to 2 stacked pairs of Dell Powerconnect 5548 (one for servers and one for users), the user 5548 stack also has 2 10 Gb connections which connect to a third Dell Powerconnect 5548 stack which is in an IDF for some more users.

Configuring LACP

So each vendor and in some cases each model of switch can do LACP slightly differently, but the basics of it are this, if the LACP protocol configurations match on both side of the connection then the LAG is successfully created.  One thing I want to make clear is that while the configuration of the protocol has to match that doesn’t mean that you execute the same commands to get there, or that the applicable running-configs will match.  Each vendor and in some cases switch firmware has its own way of configuring LACP, it is the underlying configuration which matters NOT the visible configuration.  In most cases the same terminology is used which can simplify the configuration.

Powerconnect 6248 LAG Configuration

Now this section will need to be done on the 6248 side.  I have tested this configuration with 55xx, but not with another 62xx.

Configure Port Channel (LAG)

> enable# configure
(config)# interface port-channel 2
(config-if)# description "Downlink - stack-5548-user-1"

Really all we need on the Port Channel is a description so that we know what it is.  However if you have any specific port configs then you will put them here and NOT on the port itself.  So for example below I am setting the pvid as 10.

(config-if)# switchport mode general
(config-if)# switchport general pvid 10
(config-if)# switchport general allowed vlan add 10
(config-if)# exit

Configure Port Members

> enable# configure
(config)# interface ethernet 1/xg4
(config-if)# description "stack-5548-user-1 te1/0/2"
(config-if)# channel group 2 mode auto
(config-if)# exit
(config)# interface ethernet 2/xg4
(config-if)# description "stack-5548-user-1 te2/0/2"
(config-if)# channel group 2 mode auto
(config-if)# exit

Powerconnect 5548 LAG Configuration

This section should be done on the 5548 side.  I have tested this with both the 62xx and other 55xx switches.

Configure Port Channel (LAG)

> enable# configure
(config)# interface port-channel 1
(config-if)# description "Uplink - stack-6248-core"

Really all we need on the Port Channel is a description so that we know what it is.  However if you have any specific port configs then you will put them here and NOT on the port itself.  So for example below I am setting the pvid as 10.

(config-if)# switchport mode general
(config-if)# switchport general pvid 10
(config-if)# switchport general allowed vlan add 10
(config-if)# exit

Configure Port Members

> enable# configure
(config)# interface tengigabitethernet 1/0/2
(config-if)# description "stack-6248-core 1/xg4"
(config-if)# channel group 1 mode auto
(config-if)# exit
(config)# interface tengigabitethernet 2/0/2
(config-if)# description "stack-6248-core 2/xg4"
(config-if)# channel group 1 mode auto
(config-if)# exit

Check Status

That about wraps it up the only thing left to do is check the status of our configured LAG.

Powerconnect 62xx

#show interfaces port-channel 2

Channel   Ports                         Hash Algorithm Type
-------   ----------------------------- -------------------
ch2       Active: 1/xg4, 2/xg4          3

Hash Algorithm Type
1 - Source MAC, VLAN, EtherType, source module and port Id
2 - Destination MAC, VLAN, EtherType, source module and port Id
3 - Source IP and source TCP/UDP port
4 - Destination IP and destination TCP/UDP port
5 - Source/Destination MAC, VLAN, EtherType, source MODID/port
6 - Source/Destination IP and source/destination TCP/UDP port

Powerconnect 55xx

# show interfaces port-channel 1

Load balancing: src-dst-mac.

Gathering information...
Channel  Ports
-------  -----
Po1      Active: te1/0/1-2

So we can see that both switches are showing the LAG as Active, and showing the correct memberships.  Notice that the hashing algorithm is different.  That is due to the 6248 being a L3 switch and the 5548 being L2.  Depending on the type of traffic it will negotiate that algorithm.

July 15th, 2013 | Tags: , , , , , ,

Recently I noticed that my clock was beginning to skew, and NTP wasn’t able to keep up with it.  This is due to having a “system clock” and a “hardware clock” the system clock is the one that the OS controls, while the hardware clock is controlled by the BIOS and runs on the hardware.  So all I did to resolve it was sync up the system clock and then sync the hardware clock based off of the system clock.

Update System Time from NTP Server

NTP will only handle incremental time shifts, but ntpdate will use the time source and then make one large adjustment to fix large skews, of course you could manually set the system clock too.

# ntpdate -u timeserver.local
10 Jul 10:37:19 ntpdate[6702]: adjust time server 172.16.88.208 offset 0.105388 sec

Show the Hardware Clock Time

Here we are going to take a look at the hardware clock.  This can be compared to your system clock to see if the problem is existing for you.

# hwclock --show
Wed 10 Jul 2013 10:35:04 AM CDT  -0.938189 seconds

Update the Hardware Clock with the Time from the System Clock

When you are ready to copy your time from your system clock to the hardware clock, that can be done with the following command.  You can also pull from the hardware clock if you desire.

# hwclock --systohc
July 10th, 2013 | Tags: , , , ,

Most modern switches include the ability to use SSH as a remote communications protocol.  Here we will enable that functionality and disable telnet on the Dell Powerconnect 3548 switches.

Enable SSH

In order to enable SSH we need to generate the keys which will be used by SSH to encrypt the traffic.

console>enable
console# configure
(config)# crypto key generate rsa
(config)# crypto key generate dsa
(config)# ip ssh server
(config)# exit
console# copy running-config startup-config

Disable Telnet

Depending on your config you might not need to disable this, but if it is enabled you should disable it.

console>enable
console# configure
(config)# no ip telnet server
(config)# exit
console# copy running-config startup-config
July 9th, 2013 | Tags: , , , ,

Most modern switches include the ability to use SSH as a remote communications protocol.  Here we will enable that functionality and disable telnet on the Dell Powerconnect 5548 switches.

Enable SSH

In order to enable SSH we need to generate the keys which will be used by SSH to encrypt the traffic.

console>enable
console# configure terminal
(config)# crypto key generate rsa
(config)# crypto key generate dsa
(config)# ip ssh server
(config)# exit
console# write memory

Disable Telnet

Depending on your config you might not need to disable this, but if it is enabled you should disable it.

console>enable
console# configure terminal
(config)# no ip telnet server
(config)# exit
console# write memory

 

 

 

 

July 8th, 2013 | Tags: , , , ,

Most modern switches include the ability to use SSH as a remote communications protocol.  Here we will enable that functionality and disable telnet on the Dell Powerconnect 6248 switches.

Enable SSH

In order to enable SSH we need to generate the keys which will be used by SSH to encrypt the traffic.

console>enable
console# configure
(config)# crypto key generate rsa
(config)# crypto key generate dsa
(config)# ip ssh server
(config)# exit
console# copy running-config startup-config

Disable Telnet

Depending on your config you might not need to disable this, but if it is enabled you should disable it.

console>enable
console# configure
(config)# ip telnet server disable
(config)# exit
console# copy running-config startup-config

 

Page 2 of 2512345...1020...Last »
TOP